Contribute project

Contribute, a product from Macromedia, SF-based maker of the Dreamweaver Web creation program, enables folks to have a Web presence using existing materials, pre-designed templates for their pages, and minimal time.

For full information on using Contribute see Macromedia’s online tutorials and the Peachpit press Visual QuickStart Guide to Contribute. 
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Your Contribute Key and password
The TLC’s Contribute Administrator, Luis Muniz, sends a key and, in a separate email, a password for that key, to your GroupWise email address. 
To connect to your site for the first time on any computer that has Contribute installed, open (or double-click) your key. 
Then, enter your password in the popup window. Contribute automatically opens to your home page allowing you to view or update your site. 
You need to install your Contribute key only once on each computer. The handout Your CCSF Contribute Connection Key contains full instructions.
Your Web address

To go to your site, open Internet Explorer and type http://www.ccsf.edu/yrlogin into the address box. Substitute your network/email login name for yrlogin. 

If your login name was jdoe, you would type http://www.ccsf.edu/jdoe to go to your site. 

Note: There is no tilde (~) in your site address! 
You create your pages inside Contribute and then publish them to the Web. The Contribute browser doesn’t give you an accurate picture of your pages. When you have created your website—and frequently during the creation process—check how it looks to the rest of the world by viewing using a web browser such as Internet Explorer. You (or anyone else) can do this anytime, from any Internet-connected computer.

Starting Contribute after the first time

Instructions for installing your key and starting a copy of Contribute for the first time are in the separate handout, Your CCSF Contribute Connection Key.
The first time you install your key on any computer (with Contribute already installed), Contribute opens automatically. 
After initially installing your key on any computer, edit your Website by opening Contribute on that computer and clicking the link to your site.
You must log in to your own account and install your key on every computer on which you use Contribute. This both stores your key’s information on that computer’s copy of Contribute and keeps your site connection secure from anyone else using the same computer (as long as you remember to log on and off before and after using Contribute). 
Windows

Very Important: On CCSF Windows computers, start by logging into the CCSF network with your UserID and Password—especially vital if you are using a shared computer.
To start Contribute on Windows after your first time key install, use Contribute’s Desktop icon if you see it, or the Start menu. 
To use the Start menu: Click the Start button, and then click All Programs ( Macromedia ( Contribute. (If you right-click the Contribute icon on the start menu and choose Pin to Start Menu, you’ll see Contribute’s icon as soon as you click Start). 
Then, click the link to your Web site on Contribute’s front page.

Mac
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Very Important: On CCSF Macs, start by logging into your own personal account—especially vital if you are using a shared computer. If you need to have a personal account set up on a shared Mac, contact your local ITS person or call the Help Desk (239-3711).

Open the Applications folder on your hard disk. Double click the Macromedia Contribute folder and then double-click the Contribute icon.

You may want to drag the Contribute icon to your dock to make it more easily accessible. Or, whenever you see the Contribute icon on the Dock, Control-click it and then click Keep in Dock from the popup menu.
Then, click the link to your Web site on Contribute’s front page.
Working in Contribute
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On Contribute’s front page, click the link to your site in the Begin editing my websites area. The home page (index.htm) of your Website opens for viewing and updating. 

Changing the name of your connection

The website name that Contribute lists immediately after you install your key may be simply facweb. To change to something more personal:

On the menu bar, click Edit ( My connections.
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On the My Connections Window, select the connection to your site, and click Rename.

Type in the new name—maybe your login or your full name—and click Close.
Editing pages
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When you open Contribute, you see your index page in View mode. To edit your index page, click the Edit Page button at the top of the page. 

To edit another page, click a link to that page or click the Choose button (top right) and click the page you want. When it appears in View mode, click its Edit page button.
The Connect button

Occasionally you will see a Connect button instead of Edit Page. This simply means that Contribute hasn’t yet been able to connect to the server. Click Connect and the Edit Page button should appear as usual.
Contribute’s View and Edit modes

Contribute has two modes:

1. View mode: When you enter Contribute, you see your index page. An Edit Page button appears at the top left. You can’t yet change anything on your page: you are in View mode, using Contribute’s built-in browser simply to look at the page on your Website.
2. Edit mode: When you enter Edit mode, a Publish button appears at the top left. In Edit mode you can change items on the page. You work on a draft copy that Contribute has created on your computer—the original remains on the remote server. Your changes don’t appear on the Web until you click Publish: at that point Contribute copies your updated page to the server, overwriting the old page. 
Editable and locked areas

In Edit mode, you will see two distinct areas:
1. Editable areas—marked with colored lines and a name tag. Here’s where you work: inside the colored lines you can add and change text and graphics.
2. Locked, uneditable, areas, where your cursor turns into [image: image1.png]



Editable area examples on your Index page: 

· The name and dep areas at the top.
Like most editable areas, these boxes contain placeholder text. Highlight the text and type in your own information (your name should already appear).

· The box marked opt further down the page. It contains the word Biography.

· Some people have left this alone and entered biographical text in the next field, marked bio.

· Others, who didn’t see the need for a biography, simply deleted the word and left the bio field blank.

· A few used the word Biography as a link to a new page based on the generic template. They added biographical information to this page and left the bio field on the index page blank.

· Don’t leave placeholder text in your published pages! For example, delete or replace the nonsense text in the bio area.
Adding a link + a new web page 
To insert a link and create a new page at the same time, browse to an existing page where you want to insert the link, and then click the Edit Page button.

1. Place the insertion point where you want the text representing the link, or select the text or image you want to link to the new page.
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Click the Link button.

3. Select Create New Page: The Insert Link dialog box appears. 
4. Enter the link text in the Link text text box. This text box is not available if you selected text (as in the illustration) or an image on the page.

5. In the Create new page from box, select the type of page you want to create. At CCSF you have a restricted number of preset templates to choose from. The Generic page is virtually blank and allows the greatest flexibility.

6. Important: Enter a new page title in the page title text box. 
7. Click OK. Contribute adds the link to the draft, then opens the new page in the Contribute editor. Add content and Publish when you’re ready to see your new page on your Website.

(
Tip: Contribute creates the new page in the same folder as the draft that links to it. You can change the names and locations for the page when you publish. 

To return to your draft, click its title in the Pages panel or click the Choose button (upper right). Or, in Edit mode, just click the link on the page that refers to it.

Adding a Page Title

Every page in your site must have a title. The title appears at the top of the browser window and identifies the page to anyone who bookmarks it and to search engines. The page title is not the filename of the Web page.

To add a title: 
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When you create a new page, you are forced to enter a title in the title box of the dialog box before you can proceed.

· Or, whenever you’re in Edit mode, click the Page Properties icon (or press Control-J). In the Page Properties window, enter or change a title.
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Titles can contain spaces, special characters and upper- and lower-case letters.

Adding a new web page without a link

To create a new page without immediately linking to it:

On the menu bar, click File ( New page (or press Control-N). Follow steps 4-6 above. You’ll need at some point to create a link in your site to the new page; if you publish it without creating a link, Contribute will nudge you to create one.
Linking to a page on your site

1. Select the text or image that you want to link to your page, or place the cursor where you want the text for the link to appear. 
2. On the menu bar, click the link icon and choose Drafts and Recent Pages. 
3. In the Links window, type the text that will be your link if you haven’t already, and choose the page to link to.

Deleting a page
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In View mode, browse to the page on your published site: click the Choose button (upper right) and click the page.
When you are viewing the page in Contribute, on the menu bar, click File > Delete Page. Contribute gives you a warning that links may be broken. 

If you go ahead and delete the page, Contribute displays the names of all pages that contain (now broken) links to the deleted page. Edit those pages and clean up the links.

Moving to pages other than your Home page

To edit a page other than your index page, browse to the page: 

· Click a link to that page on the current page. Or:

· Click the Browse button (upper right) and navigate to a published page on your site. Or:

· Open a draft of a page that you haven’t yet published by clicking the page in the Pages panel (upper left). If you don’t see this panel: on the menu bar, click View > Sidebar, or press F4.
Then (if you haven’t opened a draft) click the Edit Page button and start editing.

Adding Content

Typing into your page
Information on entering, editing and formatting text is in Chapter 4 of the Visual QuickStart Guide.
Try to follow cues in the template to fit in with the design. For example, the sample text in the Name field of your index page is all capital letters: enter your name and title in all caps to conform to this design standard.

Spell Checking

[image: image10.png]Repeat:table  +|—|¥]|4|



Not done automatically! In Edit mode, click the spell check toolbar icon. Spell checking works as it does in most word processors.

Creating an email link

On your index page - it's not enough to type the text of your email address in the email field. You must link the text to a live address.
The simplest way:

1. Make sure you're in Edit mode

2. Type in your email address

3. Highlight the whole address and Copy it (Edit > Copy or Control [Mac: cmd] - C)

4. Click the Link icon and choose Email address (or, on the menu bar, click Insert ( Link ( Email address).

5. Paste the text of your address in the Email address field 
(Edit > Paste or Control [Mac: cmd] - V)
Once you've clicked OK and published your page, the link will work. Or rather, it will work for Web page viewers who have an email client set up in their operating system....

Linking to a page on an external site

Select the text or image that you want to be your link, or just place the cursor where you want the linked text to appear. On the menu bar, click the link icon and choose Browse to Web page. 
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In the Insert Link window, type the text that will be your link if you need to in the Link text box. 

Type the complete Web address in the next line (it has to start with http://).

Or click the Browse button and use Contribute’s built-in browser to browse to the page to link to. When you are at the correct page, click OK.
Including text from a document

You can cut and paste text (which can be part of all of a document), or import the entire contents of a document.
To cut and paste: 

1. Place your cursor inside the Contribute page where you want to insert your material. 
2. Open the document from which you want to copy. 

3. Drag through to select the text you want to copy. 

4. Press Control-C (Mac: Command-C) or on the menu bar, click Edit > Copy.

5. Move back to the Contribute document and, in Contribute, press Control-V (Mac: Command-V) or on the menu bar, click Edit > Paste. To remove formatting or to paste text from a table without copying the table, choose Edit ( Paste as text.

To import the document’s contents (Windows only):
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In Edit mode place your cursor where you want your material to go. 

2. On the menu bar, click Insert > Microsoft Office Document.

3. Browse to the file you want to insert. Highlight it and click Open.

4. Click the top entry, Insert the contents of the document… 
5. Click OK.

Linking to a longer document

If you have a long document and don’t want to take the time to break it up and insert its contents into several Web pages, you can simply link to it. Site visitors who click the link can open or save the document on their own computers if they have the program you created it with. This is common practice with Microsoft office and Adobe Acrobat files. Note: Mac users will automatically download the file.
1. Go through the steps to insert a document as detailed above in To import the document’s contents. When you reach the Insert MS Office Document window, choose Create a link to the document.
Or: Place your cursor where you want a link, and, on the menu bar, click Insert ( Link ( File on my computer or click the Link icon and choose File on my computer.
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In the Insert Link window: 
Type in your Link Text (the text that will be linked to the file). 
3. Click the button to Browse to the file you want to link to. 
4. Highlight it and click Open. A warning appears. 
5. Click OK.
Creating a popup Window

· Tip: (Windows only) Before you click OK: If you want to have your linked documents pop up in a new window (with your page remaining open in the background), locate the Target frame box in the lower right. Click the down-arrow at the right and choose New Window. 
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Advantage: The popup window doesn’t take the student away from your site.
Adding pictures

Use pictures scaled as closely as possible to the size you need in your page. Use pictures in the GIF or JPEG formats.
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You can easily add an image to your web page by dragging an image or copying and pasting an image. Or use the Image button to select an image to add to your page. 

Click the Edit Page button if you are not already in edit mode.

To select an image to add to a draft: 

1. Click in the draft where you want the image to appear. 

2. Click the Image button in the toolbar, and then select From My Computer or From Website (if you have already uploaded an image that you want to reuse). 

3. In the dialog box, find and select the image, and then click Select or OK. 

4. The image appears in your draft. Select the image and use the Image Editing toolbar to sharpen the image, adjust the contrast, resize, or crop the image.

The Image Editing Toolbar
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The toolbar appears at the top of the editing area when you click to select a picture.
To resize a picture 

1. Select the picture on the page. The Image Editing toolbar appears. 
2. Click the Resize button. Drag the resize handles to set the image size. 

3. By default, the aspect ratio does not change. In other words, the width and height both change, ensuring the image is not skewed. To change the image's aspect ratio, press the Shift key while dragging. This is opposite of the way resizing works in other applications. Once you have released the resize handles, you will have to click the Resize button again to make another resize change.

Or, to get a specific size, enter the desired height or width value in the text field on the toolbar. Changing one size changes the other, so the image doesn’t distort.
· Note: Choosing Undo from the Edit menu resizes the image in the code back to the original size, but the image will still be resampled. The end result will likely be undesirable. Instead, choose Format ( Edit Image ( Revert to Original.

To Crop a picture
Cropping means cutting out parts of an image to focus on what is important. 

Select the picture on the page. The Editing toolbar converts to the Image Editing toolbar. Click the Crop button. Square crop handles appear on the corners and sides of the image. Drag the crop handles inward to set image size. Press Enter or Return when finished.
Adding a table
1. Place the cursor at the point in the document where you want to insert the table. 

2. Click the Table button in the toolbar, or, on the menu bar, click Insert Table. 
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Set the number of rows and columns. More can be added later if needed. 

4. Set the Width of the table. Specific width allows you to specify a certain value. 
You can specify the table width to be a certain number of pixels wide or as a percentage of the page. If you set the width to 100%, the table will extend the entire width of the editable area into which you inserted the table. 

5. Specify any border width, cell padding and cell spacing you wish. These can also be modified later. 

6. Click on a header style if you want one. Click OK to create the table.

Note: Once you have created the table, you can select it and click and drag on the lower right corner to resize it.
Editing a table: A few tips
Click the Edit Page button if you are not already in edit mode.

Click in the cell of the table you want to edit. Add, delete or change text in that cell. 
Press Tab to move to the next cell.
To add/delete a row in your Course table
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To work in a table supplied in a template (like the Course table on the Index page): 
In the small toolbar that appears when you click in a table, click the corresponding button. (You can work only with rows, not columns, in template-supplied tables.)
Use the formatting icons to left or right justify or center text inside a cell. Click to select the text first; then click the alignment you want.
Adding/Deleting rows and columns in your own tables
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To change tables that you have added (in pages created from the generic template, for example), use the Add Row or Add Column buttons from the toolbar. 

For more flexibility, right-click the table and choose from this extensive pop-up menu.
Use the formatting buttons to left or right justify or center text inside a cell.
To change the vertical alignment, select the cells you want to affect, right-click and choose Cell Properties.
Changing Table or Cell properties

Right-click inside the table and choose Table or Cell properties. Or use the Table menu.
· Table Properties allows you to change the table’s width, alignment, border thickness and color and background color.

· Table Cell Properties allows you to change the text’s horizontal and vertical alignment and individual background color.

Splitting and merging cells

Select the cell to split or the cells to merge, right-click and choose the option you want. Or select the cell(s) and then pull down the Table menu to see your choices.

Adding a table color scheme

After creating a table, you may want to add some pizzazz—Contribute has some pre-built color schemes that you can choose for your table.

Click inside the table and then, on the menu bar, click Table ( Format Table. The Basic table includes table designs that you can apply, and the Advanced tab allows you to further refine the pre-designed choices.
Further information

For an online information page on table in Contribute, open a browser and navigate to http://www.macromedia.com/support/contribute/ts/documents/tables.htm.
Publishing your changes
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After you finish making changes to a draft, publish the page to your website so others can view the updated content.

1. In the upper left toolbar, click the Publish button.

2. If you are publishing a new page,
 enter a filename: this name identifies the page to the server and is also used to link to that page. Follow the rules for filenames in the box.

3. Contribute confirms that the changes were successfully published to your website.

4. Click OK to close the confirmation message.

5. The updated page appears in your browser. You have updated the page on the server, so visitors to your Website can now also see the updated page.

· Clicking Save for Later, saves your draft page, with any changes that you have made, to the hard disk on the computer where you are working (not on the Web). 
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When you reenter Contribute—on that computer–and move to the page that you were working on Contribute displays a message that you have an unpublished draft of that page. To edit the page, click the unpublished draft link.

· Clicking Cancel abandons your changes without saving them as a draft.

· Note: Sometimes you’ll get a mysterious error saying that your page couldn’t be published. Try again. It usually works the second time!

Rolling back to an earlier version of a page

We all make mistakes. And sometimes we Publish them! Contribute keeps up to three previous version of every page that you have published. 
To go back to a previous version:
1. On the menu bar, click File ( Roll Back

2. Up to three dated versions appear at the top of a Roll Back Page window. Clicking a version bring up preview at the bottom of the window. When you see the version you want, click the Roll Back button.

3. The older version replaces the current page.

4. The version you rolled back FROM becomes an entry in the rollback list—so you can go back to it if you want.
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