
Office 2007: Intro to new features 

Most of these notes apply to Word, Excel and PowerPoint 2007. Publisher 2007 has not changed its 

interface to include most standard Office 2007 features, and I won’t cover Access. 

Compatibility with earlier Office versions 

Word, Excel and PowerPoint 2007 save new documents to the new Office 2007 formats: 

 Instead of the old .doc extension (older Word versions), Word 2007’s new format is .docx 

 Instead of the old .xls extension (older Excel versions), Excel 2007’s new format is .xlsx 

 Instead of the old .ppt extension (older PowerPoint versions), PowerPoint 2007’s new format is .pptx 

When you open an old Office document, you see 

“Compatibility Mode” in the title bar: if you just save 

the document, it remains backward compatible. 

Office button choices: Save/Save As/Convert 

New Documents: Saving Office 2007 documents produces a file in the new format. It is not 

readable by the XP/2002 and 2003 or Mac 2004 versions of Office unless the recipient has 

downloaded the (free) viewers, called “compatibility packs.”  

Windows Office XP/2002/2003 Viewer: http://tinyurl.com/y5a879 

Mac Office 2004 Viewer (OS X 10.4.8 or later only): http://tinyurl.com/3ysg57 

If you are posting documents to your online course or the internet you want them to be readable by as 

many people looking at your site as possible. To keep a document backward-compatible, you have three 

choices, all available from the new Office button (the old File menu replacement): 

1: Word: Save As Word 97-2000 Document:  
Saves as .doc—compatible with older Word versions 

2: Word: Save As – Other Formats - .rtf: The Rich Text 
format is supported by all word processors and 
preserves almost all formatting from 2007.  
After clicking Other Formats, you still have to choose 
Rich Text Format from the Save as type box. 

3: 

Word, Excel, PowerPoint: Save as … PDF: Convert to pdf for free! The only catch is that on Windows 
computers (Macs can save as PDF natively) you have to download the add-in from Microsoft—if you 
don’t already have another pdf-creation program. Find the add-in at http://tinyurl.com/lvthp. The 
Adobe PDF format is viewable with Adobe’s free viewer (already on more than 95% of all PCs). 

The Convert choice: This only shows up when you are editing a file in an older Office format. To change 
a document to the new format with the new file extension, choose Convert from the Office button.  

Click here to see 

choices 

Office Button 

http://tinyurl.com/y5a879
http://tinyurl.com/lvthp
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Generally Available new features 
These features of the Office 2007 Suite occur across Word, Excel and PowerPoint.  

File Menu Ą Office button 

The old File menu has been replaced by the Office button. Click the button to Open a file, 

Save or Save As (to save under a new name or in a new location), or Print. In addition, the 

Button menu contains the configuration and setup choices that used to be available under 

Tools > Options—now under the Options button at the bottom right of the Office button 

display.  

The Options button 

At the bottom of the Office Button display is the options button 

for most applications. This is the replacement for the old Tools 

menu, Options choice, along with a few other items. Spend 

some time looking around Options to see where things are.  

To get to AutoCorrect in Word, for instance, open the Proofing 

area. In the Save area you can tell 2007 programs to save all 

your new documents in the old Office 97-2003 format.  

Under Advanced you can increase the number of Recent 

Documents displayed more than ever before. 

 

Menu Bar Ą Ribbon 

The Ribbon at the top of the program window groups commands and presents them in the open, rather 

than hiding them inside drop-down menus and toolbars. 

 7 Tabs, holding groupings of tasks (with maybe another Add-Ins choice, as in the illustration) 

 Groups: In each tab, showing options or commands related to a task— 
groups shown above are Clipboard, Font, Paragraph, Styles, and Editing 

 Commands: A button, a box to enter information, a menu, or a combination 

The Quick Launch toolbar: At the top left of the ribbon, holds common commands. Add to or change 

the commands listed by clicking the down arrow to its right. 

The Dialog Box launcher: A right-pointing arrow in the lower right of a ribbon group. Click it to open 

additional choices for the group.  For instance, the arrow under Word’s and Excel’s Paragraph group 

(shown in the illustration) opens up a familiar set of font options: Strikethrough, subscript, etc. 

To shrink the Ribbon: Double-click the active tab. You can still click to open any tab and choose a 

command. The ribbon closes back up after you’ve finished. Double-click the active tab again to restore. 
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Live Preview 

The Wow! feature in the new Office Suite. See your document change before your eyes! Commit with a click!   

These will work most impressively if you have used styling built into the application: 

 Headings and the Normal style in Word 

 Pre-designed slide layouts, font or color schemes in PowerPoint  

 Table formatting in Excel 

TRY LIVE PREVIEW ON: FONTS, PARAGRAPH STYLES (WORD), THEMES (POWERPOINT), COLORS….  

In most 2007 applications there are pre-selected font groups, background colors, or themes to choose 

from. Hover your cursor over a choice: for example, a color scheme, Theme, or font group in Word or 

PowerPoint. The Live Preview feature immediately changes the look of the document or presentation—

while you hover—to show what it would look like if you actually made that choice.  

When you find one you like, simply click to apply that choice. If you don’t want to change, don’t click, 

and your document stays as is was 

One caveat: You’ll only see the full effect of these changes if you use built-in features (the Normal style 

and numbered headings in Word and the Slide layouts in PowerPoint).  

But you can just select text and try out different fonts, font sizes, colors, highlights: Try it! 

Like Keyboard shortcuts? 

Good news: Old Control-key commands still work (like Control+C for copy, Control+X for cut, Control+V 

for paste, Control-Z for undo).  

But there are a host of new shortcut keys for accessing the functions on the ribbon. They are meant to 

be pressed sequentially—easier for people who have difficulty holding down two keys at once. 

To see the keys available, tap the Alt key once and look at the ribbon area: keyboard shortcuts become 

visible over all available areas. Press the corresponding key to activate its command or menu. 

Microsoft’s keyboard tutorials: http://tinyurl.com/2vpab3 and  http://tinyurl.com/2u4mvz   

http://tinyurl.com/2vpab3
http://tinyurl.com/2u4mvz
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Commands when you need them 

Some commands only appear when you need them: e.g. Picture or chart tools only appear when you 

click on a picture or chart to select it in your document. When you are working on the chart, the tools 

are visible. If you click away from the chart, they disappear. To get them back, click on the picture or 

chart again. 

The tools may not actually appear: but their tab appears above the ribbon. Click that tab to bring the 

tools into view. Clicking away from the picture will make these tabs and tools disappear. Here’s an 

example: The Picture Tools tab appears when you click on a picture (first illustration); If you click the 

Picture Tools tab, its tool choices appear (second illustration). 

 

 

Popup Toolbars 

When you highlight text in Word or PowerPoint 2007, 

you’ll see a ghostly toolbar if you look carefully (really). To 

make it fade into reality from its ghostly status, move your 

cursor into it. It provides quick formatting choices. 

In Excel, as well as Word and PowerPoint, you can see the same toolbar along with many other choices 

by right-clicking an entry. 

Inserting Graphics 

Now on the Insert tab, the Insert Picture and Insert Clip Art options are available as before—the main 

difference being all the new Clip Art and the streamlined connection with Microsoft’s online Clip Art 

repository. But the other options in the Illustrations group have been beefed up. 

Shapes 

Click the Shapes icon on the Insert tab; then click a shape to draw it on 

your documents. OK, so most of them were on the old Drawing toolbar—

now they are much more accessible. And once you’ve drawn one on your 

page, the Drawing tools tab appears giving you quick access to colors, 

gradients, shadows and many other enhancements. 
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SmartArt 

Arranged by category to illustrate process, cycle, hierarchy, these shapes can help you represent ideas 

graphically: 

 

Clicking a SmartArt shape on your page displays a tab with many tools to configure it easily—for 

example, you can pick a pre-configured color or gradient for your shape. 

Charts 

Now Excel’s (improved) charting module is available from the Insert tab throughout Office 2007. There is 

a wide variety of chart types, colors and configurations. And it’s easy to change your mind, so you can 

see what style best conveys your message. 

Tables 

On the Insert tab. Creating and configuring snazzy tables is so easy! Now you can choose from built-in 

color and shading designs to make your data stand out. 

Password protection 

Now you can easily add a password to a word document saved 

in Office 2007’s native format. Use the Prepare choice from the 

Office button menu, and then Encrypt the document. You’ll be 

asked to enter a password twice to confirm it. Then anyone 

wanting to open the document will have to enter that 

password—including you.  

Just don’t forget the password once you’ve saved! 
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Online Guides and tutorials 

General Intros 

Use the Internet Explorer browser for the Tutorial on Office 2007 features: 

http://office.microsoft.com/training/training.aspx?AssetID=RC101482291033  

Using examples from Word, and Excel this general intro covers: 

 Using the ribbon—the replacement for the old menus 

 On-demand ribbon tabs and commands for handling pictures, etc. 

 “Live Preview”: highlight formatting options to see effects before committing 

 Customizing the Quick Access Toolbar for the way you work by right-clicking a command 

You can try the new facilities yourself by doing a practice session after the demo. 

A second intro at http://tinyurl.com/2rmzqc  concentrates on: 

 The new Office Button (replacing the old File menu and some of the old Tools menu options) 

 Using keyboard shortcuts 

 Compatibility issues with the new file formats 

Word 

 Quick Reference Card: Guide to most-used features and links to demos and training, including some 

listed here: http://tinyurl.com/yu2wfr   

 Microsoft Word 2007 Home page: http://tinyurl.com/2mpftj  

 What’s new in Word 2007: http://tinyurl.com/2wapc8: A handy listing of new features. 

 Word’s new “Building Blocks:” Pre-designed Headers, Footers, Text Boxes, Cover Pages and more, 

that you can insert with one click: http://office.microsoft.com/en-us/word/HA102445941033.aspx  

 Guide to keyboard shortcuts: http://tinyurl.com/yoml25 and  http://tinyurl.com/2u4mvz  

 Guide to Microsoft’s online training for Word: http://tinyurl.com/2f3ndy  

Descriptions of the training modules for the application on the Microsoft site with links to go directly 

to them. 

 Microsoft Word Online Training. Training modules with text, pictures and video segments. Mostly 

really well done: http://tinyurl.com/2vpab3 

 Kewl! Commands—old Ą new: Clever interactive online guide showing Office 2002/2003 Word 

commands and where to find them in Word 2007. Use on the Web or download to your own 

(Windows) computer: http://tinyurl.com/24654r 

Excel 

 Microsoft Excel 2007 home page: http://tinyurl.com/tzzx7  

 What’s new in Excel 2007: http://tinyurl.com/2g295n: A handy listing of new features. 

 Guide to Microsoft’s online training for Excel: http://tinyurl.com/2xsthd 

Descriptions of the training modules for the application on the Microsoft site with links to go directly 

to them. 

http://office.microsoft.com/training/training.aspx?AssetID=RC101482291033
http://tinyurl.com/2rmzqc
http://tinyurl.com/yu2wfr
http://tinyurl.com/2wapc8
http://office.microsoft.com/en-us/word/HA102445941033.aspx
http://tinyurl.com/yoml25
http://tinyurl.com/2u4mvz
http://tinyurl.com/2f3ndy
http://tinyurl.com/2vpab3
http://tinyurl.com/2xsthd
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 Microsoft Excel Online Training: http://tinyurl.com/3dakry  

Training modules with text, pictures and video segments. Mostly really well done. 

 Cool: Live command translations: Live online guide showing Excel 2002/2003 commands and where 

to find them in Excel 2007: http://tinyurl.com/2wwc59  

PowerPoint 

 Microsoft PowerPoint 2007 home page: http://tinyurl.com/y4qw45 

 What’s new in PowerPoint 2007: http://tinyurl.com/ypwuyx: A handy listing of new features. 

 Guide to Microsoft’s online training for PowerPoint: http://tinyurl.com/2cw8v4 

Descriptions of the training modules for the application on the Microsoft site with links to go directly 

to them. 

 Microsoft PowerPoint Online Training: http://tinyurl.com/2mnpjf  

Training modules with text, pictures and video segments. 

 PowerPoint 2007 Demos: http://tinyurl.com/36lwxr 

 Commands: Cool live online guide dynamically showing PowerPoint  2002/2003 commands and 

where to find them in PowerPoint 2007: http://tinyurl.com/2nlc37  

 

 

http://tinyurl.com/3dakry
http://tinyurl.com/2wwc59
http://tinyurl.com/y4qw45
http://tinyurl.com/ypwuyx
http://tinyurl.com/2cw8v4
http://tinyurl.com/2mnpjf

