Contribute Pilot project

Contribute, a product from Macromedia, SF-based maker of the Dreamweaver Web creation program, enables folks to have a Web presence using existing materials and minimal time.

This handout briefly supplements the Visual QuickStart Guide to Contribute. It supplies CCSF-specific material and pulls out some key points for quick reference.
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Using Contribute to create your CCSF Website
In CCSF’s Contribute project, support staff sets up a pre-designed index (home) page for you to use as the starting point for your own, personalized site. To create additional pages, you have access to several templates created by a designer (and approved by the appropriate CCSF committees). 
The blank site awaits information that you will supply for the world to see.

Your Web address: Checking your Website
You create your pages inside Contribute and then publish them to the Web. The Contribute browser doesn’t give you an accurate picture of your pages. When you have created your website—and frequently during the creation process—check how it looks to the rest of the world by viewing using a web browser such as Internet Explorer. You (and everyone else) can do this at any time, from any Internet-connected computer in the world. 
To go to your site, open Internet Explorer and type http://www.ccsf.edu/yrlogin into the address box. Substitute your network/email login name for yrlogin. 

If your login name was jdoe, you would type http://www.ccsf.edu/jdoe to go to your site. 

Note: There are no ~ tildes in your site address!
Starting Contribute after the first time
This presumes that you have connected Contribute to your site using your key and its password, as outlined in the handout Your CCSF Contribute Connection Key.
You must install your key on every computer on which you use Contribute, as its information is stored locally. After you have initially installed your key, edit your Website by opening Contribute and clicking its link to your site.
Windows

On CCSF Windows computers, start by logging into the CCSF network with your UserID and Password—especially important if you are using a shared computer.
To start Contribute on Windows after your first time key install, use Contribute’s Desktop icon if you see it, or use the Start menu. 
TO use the Start menu: Click the Start button, and then click All Programs ( Macromedia ( Contribute. (If you right-click the Contribute icon on the start menu and choose Pin to Start Menu, you’ll see Contribute as soon as you click Start). 
Mac

On CCSF Macs, start by logging into your own personal account—especially important if you are using a shared computer. If you need to have a personal account set up on a shared Mac, contact your local ITS person or call the Help Desk (239-3711).
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Open the Applications folder on your hard disk. Double click the Macromedia Contribute folder and then double-click the Contribute icon. (You may want to drag the Contribute icon to your dock to make it more easily accessible. Or, whenever you see the Contribute icon on the Dock, Control-click it and then click Keep in Dock from the popup menu.)

Working in Contribute

[image: image2.png]Begin editing my websites
B T



On Contribute’s front page, click the link to your site in the Begin editing my websites area. The home page (index.htm) of your Website opens for viewing and updating. 

Contribute’s View and Edit modes
Contribute has two modes:

1. View mode: When you enter Contribute, you see your index page. You are in View mode, using Contribute’s built-in browser to look at the page on your Website. In View mode you can’t change anything on the page: you don’t see colored lines around the editable parts of the page or the named tabs for editable sections. You have an Edit button at the top left of the page to open the page in Edit mode so that you can make changes.
2. Edit mode: When you enter Edit mode, Contribute opens a draft copy of the page in its editor. A Publish button now appears at the top left. You work on the draft copy on your computer—the original remains on the remote server. Your changes won’t appear on the Web until you click Publish: then Contribute copies them to the server, overwriting the old page. 
After publishing, open Internet Explorer and navigate to your page: you should see the changes you made.
The templates that you work with set off two distinct areas:
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Editable areas where you can add and change text and graphics (marked off with colored lines and a name tag), and 

· Locked, uneditable, areas, where your cursor turns into

Editing page
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When you open Contribute, you see your index page in View mode. To start editing your index page, click the Edit Page button at the top of the page.
Moving to pages other than your Home page

To edit a page other than your index page, browse to the page: 
· Click a link to that page on the current page. Or:

· Click the Browse button (upper right) and navigate to a published page on your site. Or:

· Open a draft of a page that you haven’t yet published by clicking the page in the Pages panel (upper left). If you don’t see this panel: on the menu bar, click View > Sidebar, or press F4.
Then (if you haven’t opened a draft) click the Edit Page button and start editing.

Adding a Page Title

Every page in your site must have a title. The title appears at the top of the browser window and identifies the page to anyone who bookmarks it and to search engines. The page title is not the filename of the Web page.
To add a title: 
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When you add a new page, enter a title in the title box of the dialog box.
· Or, whenever you’re in Edit mode, click the Page Properties icon (or press Control-J). In the Page Properties window, enter or change a title.
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Titles can contain spaces, special characters and upper- and lower-case letters.
Adding a link + a new web page 
To insert a link and create a new page at the same time, browse to an existing page where you want to insert the link, and then click the Edit Page button.

1. Place the insertion point where you want the text representing the link, or select the text or image you want to link to the new page.
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Click the Link button.

3. Select Create New Page: The Insert Link dialog box appears. 
4. Enter the link text in the Link text text box. This text box is not available if you selected text (as in the illustration) or an image on the page.

5. In the Create new page from box, select the type of page you want to create. At CCSF you have a restricted number of preset templates to choose from. The Generic page is virtually blank and allows the greatest flexibility.

6. Important: Enter a new page title in the page title text box. 
7. Click OK. Contribute adds the link to the draft, then opens the new page in the Contribute editor. Add content and Publish when you’re ready to see your new page on your Website.

(Note: Contribute creates the new page in the same folder as the draft that links to it. When you publish the draft, you can change the names and locations for the page. (See page 44, steps 7-8 in the Visual QuickStart Guide for further directions.)

To return to your draft, click its title in the Pages panel or click the Choose button (upper right). Or, in Edit mode, just click the link on the page that refers to it.

Adding a new web page without a link

To create a new page without immediately linking to it:

On the menu bar, click File > New page (or press Control-N). Follow steps 4-6 above. You’ll need at some point to create a link in your site to the new page; if you publish it without creating a link, Contribute will nudge you to create a link.
Linking to a page on your site

1. Select the text or image that you want to link to your page, or place the cursor where you want the text for the link to appear. 
2. On the menu bar, click the link icon and choose Drafts and Recent Pages. 
3. In the Links window, type the text that will be your link if you haven’t already, and choose the page to link to.

Deleting a page
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In View mode, browse to the page on your published site: click the Choose button (upper right) and click the page.
When you are viewing the page in Contribute, on the menu bar, click File > Delete Page. Contribute gives you a warning that links may be broken. 

If you go ahead and delete the page, Contribute displays the names of all pages that contain (now broken) links to the deleted page. Edit those pages and clean up the links.

Adding Content

Typing into your page
Information on entering, editing and formatting text is in Chapter 4 of the Visual QuickStart Guide.
Try to follow cues in the template to fit in with the design. For example, the sample text in the Name field of your index page is all capital letters: enter your name and title in all caps to conform to this design standard.

Linking to a page on an external site

Select the text or image that you want to be your link, or just place the cursor where you want the linked text to appear. On the menu bar, click the link icon and choose Browse to Web page. 
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In the Insert Link window, type the text that will be your link if you need to in the Link text box. 

Type the complete Web address in the next line (it has to start with http://).

Or click the Browse button and use Contribute’s built-in browser to browse to the page to link to. When you are at the correct page, click OK.
Including text from a document

You can cut and paste text (which can be part of all of a document), or import the entire contents of a document.
To cut and paste: 

1. Place your cursor inside the Contribute page where you want to insert your material. 
2. Open the document from which you want to copy. 

3. Drag through to select the text you want to copy. 

4. Press Control-C (Mac: Command-C) or on the menu bar, click Edit > Copy.

5. Move back to the Contribute document and, in Contribute, press Control-V (Mac: Command-V) or on the menu bar, click Edit > Paste. To remove formatting or to paste text from a table without copying the table, choose Edit > Paste as text.

To import the document’s contents:

1. In Edit mode place your cursor where you want your material to go. 
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On the menu bar, click Insert > Microsoft Office Document.

3. Browse to the file you want to insert. Highlight it and click Open.

4. Click the top entry, Insert the contents of the document… 
5. Click OK.

FlashPaper is a new, still unfamiliar, Macromedia format. It usually greatly reduces the size of the content you are inserting, but may not be easily accessible to your viewers (it can’t be read by screen readers, for example).
Spell Checking
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Not done automatically! In Edit mode, click the spell check toolbar icon. Spell checking works as it does in most word processors.

Linking to a longer document

If you have a long document and don’t want to break it up and insert its contents into several Web pages, you can simply link to it. Site visitors who click the link can open or save the document on their own computers if they have the program you created it with. This is common practice with Microsoft office and Adobe Acrobat files.

Go through the steps to insert a document as detailed in Including text from a document on page 5. When you reach the Insert MS Office Document window, choose Create a link to this document.
Or: Place your cursor where you want a link, and, on the menu bar, click Insert > Link > File on my computer. Or click the Link icon and choose File on my computer.

· Insert Link Text (the text that will be linked to the file) and browse to the file you want to link to. Highlight it and click Open. This warning appears.
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When you publish the page with the link, Contribute makes a copy of the file on your Website. If you want to change the file, click its link on your page and edit the content of the file there. Or delete the file on your site, edit the file on your computer and re-link.
Adding pictures

Use pictures scaled as closely as possible to the size you need in your page. Use pictures in the GIF or JPEG formats. For more on pictures, see Chapter 5 in the Contribute Visual QuickStart Guide.
Adding Tables

See Chapter 7, Creating Tables, in the Contribute Visual QuickStart Guide.
Editing a table: A few tips
Click the Edit Page button if you are not already in edit mode.

Click in the cell of the table you want to edit. Add, delete or change the text in that cell. Press Tab to move to the next cell.
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To add/delete a row 
In the small toolbar that appears when you click in a table, click the corresponding button.
Use the formatting buttons to left or right justify or center text inside a cell.
Publishing your changes
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After you finish making changes to a draft, publish the page to your website so others can view the updated content.

1. In the upper left toolbar, click the Publish button.

2. If you are publishing a new page,
 enter a filename: this name identifies the page to the server and is also used to link to that page. Follow the rules for filenames in the box.

3. Contribute confirms that the changes were successfully published to your website.

(Note: Sometimes you’ll get a mysterious error saying that your page couldn’t be published. Try again. It usually works the second time!

4. Click OK to close the confirmation message.

5. The updated page appears in your browser. You have updated the page on the server, so visitors to your Website can now also see the updated page.

· Clicking Save for Later, saves your draft page, with any changes that you have made, to the hard disk on the computer where you are working (not on the Web). 
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When you reenter Contribute—on that computer–and move to the page that you were working on Contribute displays a message that you have an unpublished draft of that page. To edit the page, click the unpublished draft link.

· Clicking Cancel abandons your changes without saving them as a draft.

Rolling back to an earlier version of a page

We all make mistakes. And sometimes we Publish them! Contribute keeps up to three previous version of every page that you have published. 
To go back to a previous version:
On the menu bar, click File > Roll Back

Up to three dated versions appear at the top of a Roll Back Page window. When you click a version a preview appears at the bottom of the window. When you see the version you want, click the Roll Back button.

The older version replaces the current page.

The version you rolled back FROM becomes an entry in the rollback list—so you can go back to it if you want.





















Filename rules


No spaces


Only letters, numbers, and dash or underscore characters


Many sources recommend all lower-case letters
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